Converting MicroSim® Schematics Designs to OrCAD Capture® Designs

Quick Start
Contents

Before you begin
OrCAD Schematics-to-Capture translator overview ............... vi
How to use this guide ........................................ vii
Symbols and conventions ....................................... vii
Related documentation ....................................... viii

Chapter 1  Translating designs
Overview ......................................................... 11
About the translator ........................................... 12
Starting the Translator .......................................... 13
Translating designs ............................................ 14
  Translating from within Capture .......................... 14
  Translating stand-alone .................................... 17
What you may see in your translated design ................... 19

Chapter 2  Getting started in Capture
Overview ......................................................... 23
What you gain by moving to Capture .......................... 24
  Design management features ............................... 24
  Learning aids ................................................ 25
Tips for working in Capture ................................... 26
  Project and design management ......................... 26
  Ground Symbols ........................................... 27
  Viewing messages ........................................... 28
  Configuring libraries ...................................... 28
  Placing and drawing items ................................ 29
  Labeling wires ............................................. 30
  Selecting and moving items ............................... 30
  Editing parts ............................................... 31
## Contents

<table>
<thead>
<tr>
<th>Appendix A</th>
<th>Command reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>Commands</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Overview</td>
<td>33</td>
</tr>
<tr>
<td>Commands</td>
<td>34</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Appendix B</th>
<th>Terminology reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>Terminology</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Overview</td>
<td>37</td>
</tr>
<tr>
<td>Terminology</td>
<td>38</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Appendix C</th>
<th>Translator mapping file</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>What is the translator mapping file?</td>
</tr>
<tr>
<td></td>
<td>Using the file</td>
</tr>
<tr>
<td></td>
<td>Formatting records</td>
</tr>
<tr>
<td></td>
<td>Writing a scope record</td>
</tr>
<tr>
<td></td>
<td>Writing a rule record</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Overview</td>
<td>39</td>
</tr>
<tr>
<td>What is the translator mapping file?</td>
<td>40</td>
</tr>
<tr>
<td>Using the file</td>
<td>41</td>
</tr>
<tr>
<td>Formatting records</td>
<td>41</td>
</tr>
<tr>
<td>Writing a scope record</td>
<td>41</td>
</tr>
<tr>
<td>Writing a rule record</td>
<td>43</td>
</tr>
</tbody>
</table>

## Index
Before you begin

OrCAD® offers a total solution for your core design tasks: schematic- and VHDL-based design entry; FPGA and CPLD design synthesis; digital, analog, and mixed-signal simulation; and printed circuit board layout. What’s more, OrCAD’s products are a suite of applications built around an engineer’s design flow—not just a collection of independently developed point tools. The Schematics-to-Capture translator is just one element in OrCAD’s total solution design flow.
OrCAD Schematics-to-Capture translator overview

The Schematics-to-Capture translator converts MicroSim schematics, symbol libraries, and package libraries to OrCAD Capture Release 9 designs and libraries. You can translate designs generated in MicroSim Schematics versions 5.4 to 8.0.
How to use this guide

This guide is designed so you can quickly find the information you need to use PSpice A/D. To help you learn and use PSpice A/D efficiently, this manual is organized by tasks, beginning with simulation basics and design entry (parts one and two), and moving on to more advanced concepts (parts three and four).

Symbols and conventions

OrCAD printed documentation uses a few special symbols and conventions.

<table>
<thead>
<tr>
<th>Notation</th>
<th>Examples</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>C +r</td>
<td>Press C +r</td>
<td>Means to hold down the C key while pressing r.</td>
</tr>
<tr>
<td>A , f , o</td>
<td>From the File menu, choose Open (A , f , o )</td>
<td>Means that you have two options. You can use the mouse to choose the Open command from the File menu, or you can press each of the keys in parentheses in order: first A , then f , then o .</td>
</tr>
<tr>
<td>Monospace font</td>
<td>In the Part Name text box, type PARAM.</td>
<td>Text that you type is shown in monospace font. In the example, you type the characters P , A , R , A , and M.</td>
</tr>
<tr>
<td>. MODEL MLOAD NMOS + ( LEVEL=1 VTO=0.7 Cj=0.02pF)</td>
<td>Examples of syntax, netlist output, and source code are displayed in monospace font. The example shows an example of the syntax for the PSpice .MODEL statement.</td>
<td></td>
</tr>
<tr>
<td>UPPERCASE</td>
<td>In Capture, open CLIPPERA.DSN.</td>
<td>Path and filenames are shown in uppercase. In the example, you open the design file named CLIPPERA.DSN.</td>
</tr>
<tr>
<td>Italic</td>
<td>In Capture, save design_name.DSN.</td>
<td>Information that you are to provide is shown in italics. In the example, you save the design with a name of your choice, but it must have an extension of .DSN.</td>
</tr>
</tbody>
</table>
**Related documentation**

In addition to this guide, you can find technical product information in the online help, the online interactive tutorial, online books, OrCAD’s technical web site, as well as other books. The table below describes the types of technical documentation provided with PSpice A/D.

<table>
<thead>
<tr>
<th>This documentation component</th>
<th>Provides this . . .</th>
</tr>
</thead>
</table>
| Online help                            | Comprehensive information about PSpice A/D. If you can’t find something in the PSpice A/D & Basics User’s Guide, look in the online help. You can access help from the Help menu in PSpice A/D, by choosing the Help button in a dialog box, or by pressing F1. Topics include:  
  - Explanations and instructions for common tasks.  
  - Descriptions of menu commands, dialog boxes, tools on the toolbar and tool palettes, and the status bar.  
  - Netlist format samples, error messages, and glossary terms.  
  - Reference information.  
  - Product support information.  
  You can get context-sensitive help for a error message by placing your cursor in the error message line in the session log and pressing F1. |
| Online interactive tutorial            | A series of self-paced interactive lessons. You can practice what you’ve learned by going through the tutorial’s specially designed exercises that interact directly with Capture. You can start the tutorial by choosing Learning Capture from the Help menu. |
| Online OrCAD PSpice A/D Reference Manual | Reference material for PSpice A/D. Also included: detailed descriptions of the simulation controls and analysis specifications, start-up option definitions, and a list of device types in the analog and digital model libraries. User interface commands are provided to instruct you on each of the screen commands. |
| Online OrCAD PSpice Library List        | A complete list of the analog and digital parts in the model and symbol libraries.                      |
| Online OrCAD PSpice A/D User’s Guide    | An online, searchable version of this guide.                                                             |
Converting MicroSim Schematics Designs to OrCAD Capture Designs

Before you begin

Online PSpice A/D Quick Reference Card

Concise descriptions of the commands, shortcuts, and tools available in PSpice A/D.

ODN—OrCAD Design Network

www.orcad.com/odn

An internet-based technical support solution. ODN provides a variety of options for receiving and accessing design and technical information. ODN provides:

- A Knowledge Base with thousands of answers to questions on topics ranging from schematic design entry and VHDL-based programmable logic design to printed circuit board layout methodologies.

- A Knowledge Exchange forum for you to exchange information, ideas, and dialog with OrCAD users and technical experts from around the world. A list of new postings appears each time you visit the Knowledge Exchange, for a quick update of what’s new since your last visit.

- Tech Tips that deliver up-to-the-minute product information in your email box. Stay informed about the latest advances, tips, and announcements on your OrCAD product.

- Online technical support via the Tech Support Connection. Use this service to submit technical support incidents online. Create submissions, upload files, track your incidents and add comments directly into OrCAD’s support database.
Overview

This chapter explains how to set up and use the Schematics-to-Capture translator to migrate designs created with MicroSim Schematics to OrCAD Capture Release 9.

The following sections are included:

- *About the translator* on page 12
- *Starting the Translator* on page 13
- *What you may see in your translated design* on page 19
- *What does not translate* on page 22
About the translator

The Schematics-to-Capture translator converts MicroSim schematics, symbol libraries, and package libraries to Capture Release 9 designs and libraries. You can translate designs generated in MicroSim Schematics from versions 5.4 to 8.0.

**Note** Wherever possible, the connectivity of the original schematic is maintained, and the “look” of the translated schematics and symbols is the same as the “look” of the originals. Where this is not possible, warning messages are displayed and the resulting design will require some editing.

Capture combines package information with symbol definitions. For this reason, symbol libraries and package libraries are translated together; they cannot be translated separately. If a symbol library does not have a corresponding package library, then the translator generates default packages using the symbols’ pin numbers.

See Warning messages on page 14 for more information; see What you may see in your translated design on page 19 for descriptions and work-arounds of items needing editing.
Starting the Translator

The translator is started within Capture.

To start the translator

1. From the File menu, choose Import Design.
   The Import Design dialog box appears.
Translating designs

The symbols used in MicroSim Schematics are translated along with the design file; therefore, your MicroSim symbol libraries must be installed. Also, the MSIM.INI (configuration) file must be installed.

Translating from within Capture

Use the translator from within Capture when you want to translate a single schematic and have it immediately ready for editing.

Warning messages

Wherever possible, the electrical connectivity and the “look” of the translated schematic pages (and symbols) are the same as the originals. Where this is not possible, warning messages are displayed in the Capture Session Log that tell you which items need to be edited. For descriptions of the items that may need editing, see What you may see in your translated design on page 19.

To translate a single- or multi-page design

1 From the File menu, choose Import Design. The Import Design dialog box appears.
2 Click the PSpice tab.
3 In the Open text box, enter the path for the original Schematics design file, or use the Browse button to find the file.
4 In the Save As text box, enter the directory where you want to save the translated design, or use the Browse button to specify a path. The default location is the directory of the original Schematics file. The default name is the same as the original Schematics file name with an .OPJ extension.
In the MSIM.INI file text box, enter the location of MSIM.INI, if it is not already shown. This is normally found in the Windows directory.

Click OK.

The translated schematic appears in the Capture schematic page editor and is ready for editing.

**To translate a design with hierarchical blocks**

1. From the File menu, choose Import Design.
   
The Import Design dialog box appears.

2. Click the PSpice tab.

3. In the Open text box, enter the path for the original Schematics design file that contains a hierarchy, or use the Browse button to find the file.

4. In the Save As text box, enter the directory where you want to save the translated design, or use the Browse button to specify a path. The default location is the directory of the original Schematics file. The default name is the same as the original Schematics file name with an .OPJ extension.

5. In the MSIM.INI file text box, enter the location of MSIM.INI, if it is not already shown. This is normally found in the Windows directory.

6. Select the Translate Hierarchy checkbox.

7. Select the Consolidate all Schematic files into one Design file checkbox.

8. Click OK.
   
The Project Manager appears.

   All the schematics referenced in that design are listed.

**Note**

- If the design uses multiple views, the default implementation given to hierarchical blocks is the implementation for PSpice.

   All sub-schematics for hierarchical blocks are translated as well and they are consolidated into the single design file.

   See Multiple Views on page 21.
To translate a symbol library

1. From the File menu, choose Import Design. The Import Design dialog box appears.
2. Click the PSpice tab.
3. In the Open text box, enter the path for the MicroSim symbol library (*.SLB), or use the Browse button to find the file.
4. In the Save As text box, enter the directory where you want to save the translated library, or use the Browse button to specify a path. The default location is the directory of the original library. The default name is the same as the original Schematics file name with an .OPJ extension.
5. Change the filename extension from .OPJ to .OLB.
6. In the MSIM.INI file text box, enter the location of MSIM.INI, if it is not already shown. This is normally found in the Windows directory.
7. Click OK.

An OrCAD part library (*.OLB) is created, and the Capture project manager appears. When the project manager window is maximized, the Capture title bar says:

OrCAD Capture for Windows - [library name]

To translate a symbol library with hierarchy

1. From the File menu, choose Import Design. The Import Design dialog box appears.
2. Click the PSpice tab.
3. In the Open text box, enter the path for the MicroSim symbol library (*.SLB) that contains hierarchical symbols, or use the Browse button to find the file.

For each symbol:

- If there is a package library, then the pin numbers will come from the package. When there are multiple gates, you can choose View Package and see multiple packages.
- If there is no package library then the pin numbers will come from the symbol.
4 In the Save As text box, enter the directory where you want to save the translated library and design, or use the Browse button to specify a path. The default location is the directory of the original schematic. The default name is the same as the original Schematics file name with an .OPJ extension.

5 In the MSIM.INI file text box, enter the location of MSIM.INI, if it is not already shown. This is normally found in the Windows directory.

6 Select the Translate Hierarchy checkbox.

7 Select the Consolidate all Schematic files into one Design file checkbox.

8 Click OK.

A Capture library (*.OLB) is created, and the Capture project manager appears.

All of the symbol and package information is stored in the part library (*.OLB) and the schematics for any hierarchical symbols are stored in the same library. Each hierarchical part will have a schematic folder with the same name in the library.

Translating stand-alone

Use the stand-alone translator when you simply want to translate a set of designs or symbol libraries, without opening all the converted files immediately in Capture.
To translate in stand-alone mode

1. From the Start menu, choose Run.
2. Enter the path and filename for SCH2CAP.EXE and click OK.
   
   The Import Design dialog box appears.
3. In the Open text box, click Browse.
   
   Select the file (or range of files) you want to translate, then click OK.
4. In the Save As text box, enter the directory where you want to save the translated designs. The default location is the directory of the original Schematics file(s), or use the Browse button to specify a path.
5. In the MSIM.INI text box, enter the location of MSIM.INI, if it is not already shown. This is normally in the Windows directory.
6. Check Translate All Subschematics to translate all the subschematics in addition to the top-level schematics of a hierarchical design.
7. Check Consolidate all files to merge the schematic and library files together into one design.
8. Click OK.

You can also start the translator by double-clicking SCH2CAP.EXE in Windows Explorer.
What you may see in your translated design

Following are new items or changes you may see in your translated design. Some issues listed below require you to take some action, while the translator automatically takes the action for others. In either case, a warning is issued, keeping you informed of the situation.

**Bus labels and bundles**  Busses labeled with only one signal (for example, Bus1) are translated as wires.

Busses can only carry a contiguous sequence of signals with the same name, such as A[0-4]. Because of this, bus bundles and bundled pin names, such as A[0-1], B[0-1] or A,B,C, do not translate. You need to rename these busses in Capture.

Busses labeled with comma separators change to hyphenated sequences (for example, A[0,1,2] becomes A[0-2] and A0,A1,A2 becomes A[0-2]).

Bus labels that end in numbers (for example, Bus13[0-7]) will not be translated because these are not supported by Capture. You need to rename these busses to end in a non-numeric value.

**Text**  If the text in your original schematic used fonts that were not TrueType, that text will appear in the translated design using the default font (Arial). If you want to add more text, you need to use a TrueType font.

Text justification may be altered in the translated design because Capture does not support justification.

Annotation text boxes in the resulting schematic may have lines that wrap. MicroSim Schematics truncated words outside the text box, while OrCAD Capture wraps the word to the next line.
Connectivity via wire labels  Connectivity via wire labels works within a schematic page, but not across schematic pages; for example, a wire labeled CLK on schematic page one is not connected to CLK on schematic page two.

To maintain connectivity where the original schematic used wire labels across schematic pages, the translator adds small off-page connectors to wires.

Pin names and numbers  In Capture, you can either display all the pin names or display none. Pin names and numbers are displayed as text next to the respective pins. All pin name text is made the same point size in the translated design.

Port pins do not have names or numbers, so any names and numbers assigned to port pins in the original design are not present in the translated design.

Pin names and number positions are automatically set by Capture, relative to the pin. If pins are placed on the corners of a symbol, then the pin number orientation may be different in the translated design from the original schematic.

Translated symbol libraries may have overlapping pin names. You can correct this in the translated design by setting the font size in your schematic to be different from that of the originating symbol library.

Graphics  Symbols use only one color. If the symbols in your original schematic used multiple colors, they are one color in the translated design.

Custom colors defined in the original schematic are mapped to the closest colors available.

Xilinx and PLSyn  Designs containing symbols for Xilinx parts or symbols created using MicroSim PLSyn will translate to Capture but they will not simulate. You can delete the Xilinx or PLSyn parts and reuse the remainder of the circuit for other designs in Capture.
Symbols and parts Stimulus, current probe, initial condition, node set and PSpice command symbols all translate into parts in Capture. Annotation symbols translate into title block symbols.

Heterogeneous parts (those made up of different type gates within one package) translate into one part in Capture that has multiple gates.

AKO parts The translator duplicates attribute graphics, pins and other aspects of symbols for each instance of an AKO part.

Attributes In Capture, attributes are called properties. Pin and property names are case-sensitive. In other words, the property “VALUE” is distinct from the property “Value”. Therefore, the following property names change as shown during translation:

<table>
<thead>
<tr>
<th>Attribute before...</th>
<th>Property after...</th>
</tr>
</thead>
<tbody>
<tr>
<td>TEMPLATE</td>
<td>PSpiceTemplate</td>
</tr>
<tr>
<td>VALUE</td>
<td>Value</td>
</tr>
</tbody>
</table>

The IPIN attribute, when translated, makes hidden pins visible in Capture. A small global port is added to these.

Multiple Views If a hierarchical block or symbol contained multiple views in Schematics, all subschematics referenced are translated. However, the hierarchical block or symbol is translated to refer to the subschematic referenced by the PSpice view. You can change the hierarchical block’s or symbol’s subschematic by editing the block or part in Capture and changing its implementation.
To change implementations of hierarchical blocks

1 Double-click the hierarchical block and change the Implementation name to the name of a schematic in the hierarchy. See attaching implementation on page 38 for more information.

2 Repeat for each hierarchical block.

Variable-width pin symbol  If you translate a symbol library with symbols that contain variable-width pins, you will need to create parts with fixed-width pins. For example, instead of the FSTIM symbol, create FSTIM16 or FSTIM32.

For schematics that contain variable-width pin symbols, the translator creates fixed-width versions and places them in the design’s design cache.

Footprint mapping file  The mapping file (S2CFPMAP.TXT) is a text file you can use to control how the translator maps footprint names from the Schematics naming convention to the convention used in OrCAD Layout. You can add your custom footprint names and set how they are renamed for use in your translated design.

What does not translate

The following design objects do not translate from Schematics to Capture:

- custom borders
- no connect symbols
- viewpoints
Overview

This chapter introduces OrCAD Capture to users familiar with MicroSim Schematics. It contains the following sections to help you quickly get started using Capture:

- What you gain by moving to Capture on page 24
- Tips for working in Capture on page 26
Chapter 2    Getting started in Capture

Converting MicroSim Schematics Designs to OrCAD Capture Designs

What you gain by moving to Capture

Design management features

- Design cache, which makes designs self-contained, not affected by library changes (see design cache on page 38)
- Project manager
  - Hierarchical browser
  - Hierarchical printing
  - Hierarchical find
- Library configurations are saved per design
- Settings—such as options and preferences—can be saved per design
- EDIF import and export capability
- PDIF import capability
- Many netlist formats, including the option to write your own netlist format
- Ability to add custom utilities to the Accessories menu
- Cross-reference report of parts, including an unused gates report and a report of which libraries parts originate from
Editing capabilities

- Print preview
- True ERC capability with DRC markers
- Bookmarks
- Macro capabilities
- Right mouse button context menus
- Go To command (on the View menu) for moving to a location based on X-Y coordinates, grid location, or bookmarks
- Spreadsheet control for editing multiple objects to update properties, like package type, globally
- Ability to edit multiple parts simultaneously
- Copy by dragging an object (press and hold Ctrl key at the same time as you move the object)
- Group and Ungroup commands to group objects
- Grid lines in addition to grid dots
- Area selection and cycling through the selection
- Bus rippers
- Interactive creation of wire junctions
- Dynamic scrolling
- Improved no-connect handling (a property set for a pin, where if you move the part, the no-connect follows)
- Unconnected pin feedback (in the form of a square drawn around the pin’s hotspot)
- Lines in addition to polylines
- Ellipses
- Pattern support for filled graphics

Learning aids

- Online tutorial in addition to Help
Tips for working in Capture

Project and design management

In Capture, schematics are stored in design (.DSN) files. A .DSN file can contain all schematics associated with a design. Each schematic can have one or more pages.

Capture also creates project files (.OPJ). They contain, among other things:

- The type of the project.
- A reference to the design file (.DSN) that contains the schematics associated with the project.
- References to the analysis set-up information.
- Project specific settings, such as whether the project is to be simulated with PSpice.
- List of design-specific model, include, and stimulus libraries for PSpice.

When starting new circuits, or editing existing ones, always use the New Project and Open Project commands.

If you want to simulate designs with PSpice, it is critical that you work with project files rather than with design files. If you open the .DSN files directly for editing, you will not see the PSpice menu in Capture.
The project manager window

When you create or open an existing project, a project manager window is opened in Capture. When the project manager window is active, the set of menu commands that are available change. You can:

- View the schematics and pages in your design.
- View the set of analysis setups for your project.
- View the hierarchical structure of your design.
- Save and archive the project.
- Change DRC settings.
- Create PSpice subcircuits.
- Create additional schematic pages.
- Create additional schematics.
- Copy schematics and pages from one project into another project.
- Delete schematics and pages.
- Create different types of netlists.
- Annotate reference designators.

To switch to the project manager window while in Capture, use the Windows Menu.

Ground Symbols

To place an analog ground symbol in Capture, choose the Ground command from the Place menu. You can either use the ’0’ ground symbol or use one of the other ground symbols. However, if you use a symbol other than ’0’, you will need to rename the symbol (by double-clicking) to ’0’ for PSpice to simulate.
Ports

In MicroSim Schematics, ports were placed by choosing the Part command from the Place menu, and choosing symbols from the PORT.SLB library. In Capture, there are specific commands for placing ports. Choose the Hierarchical Port and Off-Page port commands from the Place menu.

Global ports (such as the bubble port in Schematics) are not supported. You can choose the Power command from the Place menu to place global power ports and rename them as necessary.

Viewing messages

The Capture session log is a window within Capture where messages and errors appear. This is similar to the Schematics Message Viewer.

Use the Session Log command in the Window menu to show the session log.

Configuring libraries

When you first create a new design, there are no libraries configured. You can place parts from the design cache or from any configured libraries. See Placing, editing and connecting parts and electrical symbols in the OrCAD Capture User’s Guide for more detailed information on configuring libraries.

For PSpice projects, use only part libraries that have been set up for referencing PSpice models. These are installed in the PSpice folder in Capture\Library.
Placing and drawing items

Capture has individual menu commands for placing ports, power and ground symbols, off-page connectors, and parts. In Schematics all of these different parts were listed in the Part Browser.

To place a ground, click the Ground button on the toolbar to provide a filtered list of symbols you can use.

When drawing a wire, click the Draw Wire button to enter drawing mode, then click to start the wire and place vertices. When you have finished, click the right mouse button to display the a pop-up menu, and select End Wire to end drawing mode.

Connectivity via wire labels works within a page, but not across pages; for example, a wire labeled CLK on page one is not connected to CLK on page two. To connect across pages, use off-page connectors. See Connectivity via wire labels on page 20.

Although there is a Place Junction command, junctions are created automatically when you draw a wire, if you end the wire on a wire, another wire’s endpoint, or on a part’s pin. However, placing a pin in the middle of a wire does not make a connection.

Placed text does not have Fill or Outline Box capabilities.

You can insert bitmaps (but not metafiles).

If a pin’s hotspot is unconnected, a small square is drawn around it.

Rotating a part in Capture rotates it in place, whereas in Schematics it rotated around the origin.

Mirroring a part in Capture flips a part along either the horizontal or vertical axis, whereas in Schematics it only flipped along the vertical axis.
Labeling wires

After drawing the wire, place a net alias. Click the Label Wire button, type in the net alias, press OK, then click on the wire to attach the alias. The display of the net alias on the wire labels that wire. In Capture, the net alias must be placed so that the lower, left corner touches the wire or bus.

Selecting and moving items

In Capture, you select by clicking on a wire or part. When clicking on a part, you may sometimes select a pin rather than the part itself (Capture lets you select pins for setting instance-specific pin properties). To select the part instead, you can press and hold the T key and click again to get the part. Pressing T while clicking selects the next item that is selectable at that point. As with Schematics, you can also select an item by dragging a box around it. Capture lets you define whether items get selected by being entirely within the area. See Defining your preferences in Chapter 4, in the OrCAD Capture User’s Guide.

Press C to extend your selection (instead of S in Schematics).

Also, in Capture, after selecting an item or area, pressing C while dragging copies the selection and pastes.

You can use the Group and Ungroup commands on the Edit menu to group and ungroup objects. The Group command is not available if you have any net aliases in the set of selected objects.

Zoom All includes the title block, so it is equivalent to viewing the Entire Page in Schematics. If you turn off display of the title block, Zoom All is equivalent to View Fit in Schematics.
To turn off display of the title block

1. From the Options menu, choose Schematic Page Properties.
2. Click the Grid Reference tab.
3. In the Title Block Visible group box, clear the Displayed check box.

Editing parts

In Capture, you have a choice of assigning reference designators as you place parts, or after the parts are placed. You make this choice with the Preferences command on the Options menu. If you don’t enable the Auto Reference placed parts option, reference designators are not assigned as you place parts. However, they are assigned automatically when you annotate the schematic.

A No Connect is a pin property (not a separate symbol) that stays with the part when the part is moved.

To edit a part (symbol)

1. Select a part on the schematic.
2. From the Edit menu, choose Part.

The Capture part editor appears, with the symbol that is stored in the Design Cache ready to edit.

To change a reference

1. Double-click the reference designator. The Display Properties dialog box appears.
2. Edit the value, and if needed, the display format.
3. Click OK.

Note  No libraries are configured when the schematic is first translated. Before you configure a library, you can only place parts stored in the design cache. See design cache on page 38 for more information.
How symbols are associated with package definitions

In Schematics, when a component was available in multiple package types, a single symbol was created. The package definition associated with the symbol contained a list of the package types and the pin numbering used for each package type. In Capture, separate parts are created for each package type that has different pin numbers.

When translating designs, a part for the package type used in the schematic is created. If the same part is used elsewhere on the schematic with a different package type, then a separate graphic representation is created.

By default, a single part is created for each symbol from the Schematics library. If there are multiple package types associated with a part, the first package type listed is used. This means the pin numbers on the part are those of the first package type, and the package type name is added as a property of the part.

Hierarchy blocks

To push into a hierarchical block:

1. Select the hierarchical block and click the right mouse button

2. From the pop-up menu, choose Descend Hierarchy. You can also choose Descend Hierarchy from the View menu.

To place pins, select the block, then from the Place menu, choose Hierarchical Pin.

Note that the Implementation Name is the schematic folder name.
Overview

This appendix provides a reference for the menu commands used in Schematics and their equivalent Capture 9 commands.

It contains the following section:

• Commands on page 34

See the OrCAD Capture User’s Guide and Capture’s online help for more information on how to use these or any other commands.
## Commands

<table>
<thead>
<tr>
<th>This Schematics command...</th>
<th>Is similar to this Capture command...</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File menu</strong></td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>New Project,</td>
</tr>
<tr>
<td></td>
<td>New Library</td>
</tr>
<tr>
<td>Export</td>
<td>Export to DXF</td>
</tr>
<tr>
<td><strong>Edit menu</strong></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Undo</td>
</tr>
<tr>
<td>Redo</td>
<td>Redo</td>
</tr>
<tr>
<td>Cut</td>
<td>Repeat</td>
</tr>
<tr>
<td>Copy</td>
<td>Copy</td>
</tr>
<tr>
<td>Paste</td>
<td>Paste</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>Select All</td>
<td>Select All</td>
</tr>
<tr>
<td>Attributes</td>
<td>Properties</td>
</tr>
<tr>
<td>Symbol</td>
<td>Part</td>
</tr>
<tr>
<td>Flip</td>
<td>Mirror</td>
</tr>
<tr>
<td>Rotate</td>
<td>Rotate</td>
</tr>
<tr>
<td>Find</td>
<td>Find</td>
</tr>
<tr>
<td><strong>Draw menu</strong></td>
<td></td>
</tr>
<tr>
<td>Get New Part</td>
<td>Part,</td>
</tr>
<tr>
<td></td>
<td>Off-Page Connector</td>
</tr>
<tr>
<td></td>
<td>Hierarchical Port</td>
</tr>
<tr>
<td></td>
<td>No Connect,</td>
</tr>
<tr>
<td></td>
<td>Title Block,</td>
</tr>
<tr>
<td></td>
<td>Power,</td>
</tr>
<tr>
<td></td>
<td>Ground</td>
</tr>
<tr>
<td></td>
<td>(on the Place menu)</td>
</tr>
<tr>
<td>Wire</td>
<td>Wire (on the Place menu)</td>
</tr>
<tr>
<td>double-clicking a wire</td>
<td>Net Alias</td>
</tr>
<tr>
<td></td>
<td>(on the Place menu)</td>
</tr>
<tr>
<td>Bus</td>
<td>Bus Entry (on the Place menu)</td>
</tr>
</tbody>
</table>

Other File menu commands in Capture:
- Export Selection
- Import Selection
- Print Preview

Other Edit menu commands in Capture:
- Group
- Ungroup

Other Place menu commands in Capture:
- Junction
- Bus Entry
- Bookmark
<table>
<thead>
<tr>
<th>This Schematics command...</th>
<th>Is similar to this Capture command...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block</td>
<td>Hierarchical Block (on the Place menu)</td>
</tr>
<tr>
<td>drawing a wire to the edge of a block</td>
<td>Hierarchical Pin (on the Place menu)</td>
</tr>
<tr>
<td>Box</td>
<td>Rectangle</td>
</tr>
<tr>
<td>Circle</td>
<td>Ellipse</td>
</tr>
<tr>
<td>Arc</td>
<td>Arc</td>
</tr>
<tr>
<td>Polyline</td>
<td>Line, Polyline</td>
</tr>
<tr>
<td>Insert Picture</td>
<td>Picture</td>
</tr>
<tr>
<td>Text</td>
<td>Text (on the Place menu)</td>
</tr>
</tbody>
</table>

**Navigate menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pop, Top</td>
<td>Ascend Hierarchy (on the View menu)</td>
</tr>
<tr>
<td>Push</td>
<td>Descend Hierarchy (on the View menu)</td>
</tr>
<tr>
<td>Select Page</td>
<td>Go To (on the View menu)</td>
</tr>
</tbody>
</table>

**View menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fit</td>
<td>Zoom All (if the title block is not displayed)</td>
</tr>
<tr>
<td>In</td>
<td>Zoom In</td>
</tr>
<tr>
<td>Out</td>
<td>Zoom Out</td>
</tr>
<tr>
<td>Area</td>
<td>Zoom Area</td>
</tr>
<tr>
<td>Entire Page</td>
<td>Zoom All (if the title block is displayed)</td>
</tr>
<tr>
<td>Redraw</td>
<td>Redraw</td>
</tr>
<tr>
<td>Pan–New Center</td>
<td>Zoom Selection</td>
</tr>
<tr>
<td>Toolbars</td>
<td>Toolbar, Tool Palette</td>
</tr>
<tr>
<td>Status Bar</td>
<td>Status Bar</td>
</tr>
</tbody>
</table>

**Options menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pan and Zoom</td>
<td>Preferences</td>
</tr>
<tr>
<td>Display Options</td>
<td>Preferences</td>
</tr>
</tbody>
</table>

**Other View menu commands in Capture:**
- Scale
- Grid
- Grid References

The Preferences dialog box in Capture defines settings in your Capture environment.

The Design Template dialog box defines settings in all new designs.

The Schematic Page Properties dialog box defines settings for the current schematic page only.
### This Schematics command... | Is similar to this Capture command...
---|---
Display Preferences | Preferences, Design Template
Editor Configuration | Schematic Page Properties
### Window menu
New | New Window
Tile Horizontal | Tile Horizontally
Tile Vertical | Tile Vertically
### Help menu
Keyboard Shortcuts | Commands and Tools
Library List | Reference
Schematics User’s Guide | Learning Capture
Technical Support | Product Support

#### Other Help menu commands in Capture:
- Processes
- How to Use Help
- Help for SDT Users
Overview

This appendix introduces terms and concepts specific to Capture and relates them to any similar Schematics terms and concepts.
### Terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>attaching implementation</td>
<td>Equivalent in MicroSim terminology to pushing into a hierarchical block for the first time and naming the schematic. Each hierarchical block can have only one implementation associated with it at a time.</td>
</tr>
<tr>
<td>design</td>
<td>A design file (.DSN) contains one or more schematics and a design cache.</td>
</tr>
<tr>
<td>design cache</td>
<td>Copies of each part used in a design are stored in a design cache. When you first open a schematic, no libraries are configured, but you can place parts stored in the cache. One advantage of using a design cache is that you can change a part in a library without affecting the schematic, and vice versa. This makes the design self-contained and easily archived.</td>
</tr>
<tr>
<td>footprint</td>
<td>Equivalent in MicroSim terminology to a package type.</td>
</tr>
<tr>
<td>part</td>
<td>Equivalent in MicroSim terminology to a symbol with packaging information.</td>
</tr>
<tr>
<td>part in a package</td>
<td>Equivalent in MicroSim terminology to a gate.</td>
</tr>
<tr>
<td>project</td>
<td>A project file (.OPJ) is associated with one design and contains references to the resources used in the design, such as libraries, netlists, bills of materials reports, and fuse maps.</td>
</tr>
<tr>
<td>schematic folder</td>
<td>A collection of all schematic pages at the same level of hierarchy in a design.</td>
</tr>
<tr>
<td>schematic page</td>
<td>The page on which a design is drawn.</td>
</tr>
</tbody>
</table>
Overview

This appendix explains how to use the translator mapping file to control the way that the translator manipulates attributes and footprint names.

It contains the following sections:

• What is the translator mapping file? on page 40
• What is in the file? on page 40
• Using the file on page 41
What is the translator mapping file?

The mapping file is a text file you can use to control how the translator manipulates attributes and footprint names.

What is in the file?

The file contains a scope record followed by rule records.

**The scope record**  Tells the translator which libraries and parts to apply the rules to. A scope record must precede any rule records.

**The rule records**  Define the rules for what the translator should do for the attributes and footprints of the libraries and parts contained in the scope.
Using the file

Formatting records

A record is a line of text made of fields (words or names) separated by a space or tab. The fields must follow the order given for the type of record.

All records are case-insensitive, meaning that uppercase and lowercase letters are treated the same.

Comment lines

An asterisk in the first column is considered a comment (just as in model definitions). A comment line can appear anywhere in the file. For example:

* This is a comment line
* Another comment line

The translator ignores comment text.

Writing a scope record

A scope record specifies which libraries and parts the translator applies the rules to. A scope record contains a parameter followed by a value. There are four types of scope records you can use:

- Global
- Global library
- Global part
- Specific part
Global scope
A global scope applies to all symbols in all libraries. For example:

[* *]
This will apply the rules to all the symbols in all the libraries.

Global library scope
A global library scope applies either to one specific library or to all libraries of the same name. For example:

[Port *]
This will apply the rules to all parts within any PORT.SLB.

["d:\msim_8\lib\port.slb" *]
This will apply the rules to all parts within this specific PORT.SLB file.
Long file names must be within double quotes.

Global part scope
A global part scope applies to all parts of the same name contained in all the libraries. For example:

[* agnd]
This will apply the rules to all parts named agnd in all the libraries.

Specific part scope
A specific part scope applies either to a specific part within a specific library or to a specific part in all libraries of the same name. For example:

[Port agnd]
This applies the rules to only agnd within any PORT.SLB.

["d:\msim_8\lib\port.slb" agnd]
This applies the rules to only part agnd within this specific PORT.SLB file.
Long file names must be within double quotes.
Writing a rule record

Rules specify the action to take for specified attributes or footprints. Rule records contain a command followed by the names of attributes or footprints, and rule records must be preceded by a Scope record.

A rule record has three fields:

- **Manipulator**
- **Original name**
- **New name**

**Manipulator field**

This can be one of the following:

- **ar** Rename an attribute
- **as** Skip an attribute; do not include it in the translated symbol
- **aa** Add an attribute
- **fr** Rename a footprint

If the manipulator field is not one of these, the rule is skipped and a warning message appears.

**Original name field**

For rename attribute (ar) or rename footprint (fr) rules, this is the attribute or footprint’s original name (the name that was used in the .SLB file).

For add attribute (aa) or skip attribute rules (as), the original name is the name of the attribute to add or skip.

**New name field**

This is the new name to give the translated property. This field is used only for attribute rename (ar, fr) rules.
Index

B
bus labels and bundles in the translated schematic, 19

C
Capture
  advantages of using, 24
  commands, 34
  configuring libraries, 28
  editing parts, 31
  file types, 26
  hierarchy symbols, 32
  menus, 34
  package definitions, 32
  package information and symbols, 12
  placing and drawing items, 29
  project and design management, 26
  selecting and moving items, 30
  terminology, 38
  viewing messages in, 28
  caveats about translation, 19, 22
  configuring libraries, 28
  connectivity via wire labels in the translated schematic, 20

D
differences between Capture and Schematics, 26
  display
    of pin names and numbers, 20
    of symbol graphics, 20
    of text, 19

E
editing parts in Capture, 31

F
file types used in Capture, 26

G
glossary of Capture terms, 38
  graphics in the translated schematic, 20

H
hierarchy symbols in Capture, 32
Index

Converting MicroSim Schematics Designs to OrCAD Capture Designs

M
mapping file, translator, 40
formatting, 41
menu commands in Capture, 34

P
package definitions in Capture, 32
package information and symbols in Capture, 12
pin names and numbers in the translated schematic, 20
placing and drawing items in Capture, 29
project and design management in Capture, 26

R
rule records, 43

S
scope records, 41
selecting and moving items in Capture, 30

T
terminology, 38
text in the translated schematic, 19
translating designs
stand-alone, 17
translator
caveats, 19, 22
mapping file, 40
TrueType fonts in the translated schematic, 19

V
viewing messages in Capture, 28