Jump to content
Electronics-Lab.com Community
Sign in to follow this  
makuka

NEED HELP FOR SONY KV29FX30B

Recommended Posts

[glow=red,2,300]***__-- TUBE BASE VOLTAGES CAN AND WILL!! BITE--__***[/glow]

I'm not familiar with this model but providing the chip that you refer to isn't fastened to a heatsink then this procedure is a failsafe way of finding where the fault is. It can be used on any transistor driven gun array and i always employ this method.

First check the drive circuit on the tube base, there will be a plug going from the tube base to the main board where the IC001 lives. three of these leads should be traceable to the red,green and blue drive transistor base connections. disconnect / cut the wires for the red and blue and swap them over. Then if your screen still lacks red there is a fault on the tube panel or possibly the tube itself, if your screen lacks blue then the fault lies within the RGB driver chip on the main board.

Reconnect your swapped leads and then check the tube by following the track from the 'BLUE' drive transistor to the relevant pin on the tube base socket and desolder the pin, do this with the 'RED' pin also. Then with a thin piece of insulated wire soldered to the 'BLUE' tube base boards socket pad* (see picture) touch the other end of the wire to the tube sockets 'RED' pin.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...