Jump to content
Electronics-Lab.com Community

Coil gun charger circuit


MrHeckles
 Share

Recommended Posts

Hi guys.

I have come up with a schematic for a coil gun capacitor charger circuit. It should run off a car battery (12v). It is currently set up to charge up a 50v capacitor but I designed it to go up to close to 500v (the max rating for the diode), by just changing R4.

What do you think?

BoostConverter3.jpg

Link to comment
Share on other sites

thankyou have you biult this yet and tested it  chargeing capacitors up may be very usefull , have you tried biulding the high voltage photoflash capacitor charger that ive posted you see this is unlike the typical photoflash capcitor charger circuit of any pocket camera as when you put your fingers over the 2 terminals of the capacitor of the chargeing circuit, in the camera ,you feel nothing but with the one i put together you really feel that charge when you put your finger across the high voltage photo flash capacitor then,  makeing me think that it could possibly hold more charge than it states on the capacitor , ive seen on the net a site where someone charges up a few photoflash capacitors in sieries or parralell for a coil gun , but with the photo flash capcitor circuit of the camera charger circuit he used  they circuit wont last to long as ive dismantled many camera circuits and even when ive tested them they seem to stuff up to easy if in the case of any shorts and the transisters are not easily availiable to be able to replace them here , when i try to fix it  and for most of the transisters used in them the information on then is very hard to find on the net

Link to comment
Share on other sites

  • 2 weeks later...

Well, I built it. It all seems to work (after some intial diffuculties). However I have a few questions as to its performance.

Firstly, with the pot wound right up, the best charge I can get out of the unit is 75 volts. I presume this has something to do with the frequency or duty cycle I am running the 555 timer at. I am running it at 64 kHz. With a 55% duty cycle.

I find that the circuit draws around 0.1 amps steady when set for the highest level (75 volts as above). If I wind it down somewhat (to say between 35v and 55v) then the mosfet gets real hot (and yes, that is with a big fat heat sink) and the current draw ups to around 3.8 amps. If it has a lower setting (up to about 30v) then it will charge to a level, then wait until the voltage drops by a few volts then kick in to charge back up again. It does not heat up the mosfet significantly doing this.

Why would it only heat the mosfet up in the middle ranges?

Thanks for any feedback guys

Link to comment
Share on other sites

Hi Mr. Heckles,
I think that your frequency is much too high for such a high value inductor and very slow diode "Fred". Your frequency is 43 times higher than the original circuit.

It takes time for current to build in the inductor but your high frequency stops the current just after it has started, resulting in a low output voltage. Your low duty-cycle also reduces the amount of time for the inductor to build current.
The diode is actually discharging the capacitor bank by the Moset when it is supposed to be off, resulting in heat and a further reduction in output voltage. ;D

Link to comment
Share on other sites

Righto, I changed some bits around. It is now running at 4.8 kHz with a 66% duty cycle. That seems to have fixed the limited voltage issue. I should merrily be able to blow up capacitors now :-)

As far as that diode is concerned, I am using an MR856, which according to its datasheet should have a reverse recovery time of at worst 300 ns.

Why would it be discharging the capacitor bank through the diode if this recovery time seems to be short enough?

What sort of diode should I be using to stop this from happening?

Is there another way to stop it from heating up the mosfet once it has reached its preset voltage level?

Link to comment
Share on other sites

Actually, now that I think about it, could it just be that there is too much current passing through the mosfet. After all, it says for the IRF830 that the RDS(on) is 1.5 ohms. Am I right in assuming this means that when it is on, it is going to be passing 12/1.5 = 8 amps?

Could I reduce this by placing small resistor just infront of the mosfet (between the inductor and it), say a 5 ohm or something. Would that reduce the current through the mosfet?

What effect would this have on the rest of the circuit?

Link to comment
Share on other sites


it says for the IRF830 that the RDS(on) is 1.5 ohms. Am I right in assuming this means that when it is on, it is going to be passing 12/1.5 = 8 amps?
Could I reduce this by placing small resistor just infront of the mosfet (between the inductor and it), say a 5 ohm or something. Would that reduce the current through the mosfet?

It should pass much more than only 8A. Its high resistance is limiting the current and heating it up. You need the Mosfet to be a switch, not a heater.
Don't use a series resistor, it will waste even more power.
Use a Mosfet with a much lower resistance like an IRFB20N50K. ;D



Link to comment
Share on other sites

Okay, now I am confused. I got a new mosfet of much lower resistance. This one has an Rds (on) of 0.19 ohms. It has a 20 amp rating. However. Once the capacitor reaches the preset charge level, the mosfet heats up even quicker than the last one. It reaches the preset charge very quickly (faster than the old one).

Could this overheating be due to the preset voltage cutoff system? At the lower levels of charge (up to 25v) you can see the voltage peak, and then drop a bit (about 2v or so) and then peak again. This I think is due to the effect of the 1uF cap between the transistor (not the mos, the other one, Q2 in my schematic) and the pot. But at the higher voltage levels, there is none of this drop off.

So would I be right in assuming that the mosfet is being switched on and off very quickly because the 555 timer is being reset all the time. Would this cause the super heating effect?

If this is the case. How can I overcome this? Do I need a much bigger(or smaller) capacitor, or perhaps a different type? It is a 1uF electrolytic at the moment.

Link to comment
Share on other sites

Hi MrHeckles,
The circuit doesn't have "a 1uF capacitor between the 2N3904 transistor and the pot".
It has a 0.1uF capacitor from the transistor's base to ground to hold a charge when the preset voltage is reached to keep the transistor turned on which turns off the 555 until the output voltage decays a little. With a capacitor value 10 times too high, the output voltage will decay more before the 555 starts the Mosfet charging the capacitor bank again.

Doesn't the "LED deliver" turn off when the preset voltage is reached? If so, then the 555 is held in reset and the Mosfet is turned off. When the Mosfet is off it can't heat-up unless its zener diode is conducting because the Mosfet's voltage rating is too low.

Which Mosfet are you using?
What output voltage causes the "super-heating" effect?

Double-check the wiring of the pins of the 2N3904. If its emitter and collector pins are reversed, it will work a little but not properly.

post-1706-14279142394876_thumb.png

Link to comment
Share on other sites

Just to clarify, my circuit is a little different from the one the anotherforummember posted.

Here is the latest schematic of mine.



I understand the mosfet wont be heating during the off period (hence the advantage to a larger cap from the transistors base), however I am curious as to what happens during the turning on and turning off times of the mosfet. Does it generate alot of heat at this time, or is heat generation only due to the current passed through it while on?

The mosfet I am using now is the SPP20N60S5. The extreme heat up occurs at any voltage preset between 35v and 100v (I dont go higher because of the main capacitors I have are only rated to 100v). Below 35v there seems to be enough time between charge-up bursts to keep heat under control.

The transistor is the right way round. I checked.

Last important question, in regards to a 2N3904 transistor. How much voltage and current is needed to turn it on?

Link to comment
Share on other sites

Hi Mr. Heckles,
Your circuit is different from the original.
Your Mosfet is very nice.
Your driver IC is very nice.
But no wonder the Mosfet heats-up, is gate drive voltage is too low! :o

Even in the original circuit the gate drive voltage is too low.
Your 7808 regulator could have a 7.6V output. The gate driver could have a 1.5V loss resulting in only 6.1V for the gate of the Mosfet. The Mosfet is spec'd to turn on well with a gate voltage of 10V.

The pcb layout is extremely important for the driver to work properly as explained in its datasheet. It also explains how a 4.7uF tantalum capacitor is needed to supply it when it switches and draws a huge momentary current from the supply.

Mosfets driven from a low impedance source like your driver need a resistor between it and the gate (maybe 10 ohms?) to stop the Mosfet from oscillating.

I don't know details about your L1 inductor, it might be saturating when it becomes just a piece of wire.

The values of R3 and R4 in your circuit are extremely low and waste a lot of power.

The datasheet for the 2N3904 shows a min gain of 100 at a collector current of 20mA, therefore its base current will be 200uA or less. It shows a base turn-on voltage between 0.65V and 0.85V (they are all different). ;D

Link to comment
Share on other sites

Okay, I made some changes to the circuit. The mosfet driver is now powered from the 12v supply. I also added a schottky diode to ground between the driver and the fet, and a small value resistor. This solved the heating problems. I also upped the bleeder resistors to 100k and a 5k pot. I added a 1k resistor after the LED, and dropped the cap from the 5k pot to the transistor down to 0.01uF.

Hey hey, and now it all works swimmingly. On startup minimum charge level is about 30v, and I could wind it up to 200v with no problems. I couldnt go higher since I had no capacitors better than 200v. There was still a bit of movement left in the pot so I guess maybe 350v with this frequency setting.

It also charges very quickly, with no overheating issues.

I'll take a photo of the finished board and post it soon.

Thanks for all your help guys.

Link to comment
Share on other sites

the link to that other coil gun site now i checked it out and the 2n3094 transistor and led and 1k resister  in the circuit there used to indicate the capacitor charge ,i used those  3 componenets and intergrated them into the high voltage photo flash capacitor charger and the 1k resister kept burning out so i changed it to a 1/2 watt and it works great  and so dose the transister to , in fact the transister still tested ok even when the 1/4 watt 1k resister was burning out so  those few parts there the transister and 1k 1/2 watt resister and led , when intergrated into the high voltage photoflash capacitor charger work ok , now i used a 10k potentiometer to which i forgot to mention so with the adjustments i make with it  the led comes on or blinks when the cap is charged or something like that , so its handy to be able to intergrate a small peace of one circuit to modify another ,

Link to comment
Share on other sites

the inputs to the simple coilgun capacitor charge indicater i derived from the coil gun circuit i conect to the high voltage photoflash capacitor charger outputs that go to the capacitor being charged works well here ill post the pics of the latest high voltage photoflash capacitor charger as soon as its all finished ,complete with the circuit from the coilgun circuit

Link to comment
Share on other sites

  • 1 month later...

:)heres the latest picture, this time ive solderd the protection diodes in place and ran the input wires to the coil , i used 3x 1n5408 diodes and when i charged up the 200 volts 1200uf electro and dumped the charge into the coilgun it went faster, maybe the settings on the high voltage photo flash capacitor charger, i got in the right positions so i got a better charge

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
  • Create New...