Jump to content
Electronics-Lab.com Community
Sign in to follow this  
omer_faruk

amp problem

Recommended Posts

Hi Omer,
What is a "tis" goming sound?
Is it high frequency noise that sounds like and we call "hiss"?

If it goes away when you disconnect an input then the noise comes from the source that feeds that input.

If the hiss noise comes from the amp then is the amp a manufactured one or an amp you built yourself? Please post its schematic. ;D

Share this post


Link to post
Share on other sites

Hi omer_faruk :

    As far as you said this problem,it is probability the noise to cause.Especially power circuit is clean output!? If it has 50~60Hz frequency,then it will cause this problem.You can check this point first. :)


Best Regards,

            Stanley

Share this post


Link to post
Share on other sites

Does the hiss sound go away when you disconnect the input to the amp?
Was the amp good before and the hiss sound is a new problem?
Did you add new speakers with better or peaky tweeters?
Is the amp trying to whisper something to you? ;D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...