Jump to content
Electronics-Lab.com Community

0-30 Vdc Stabilized Power Supply


Sallala
 Share

Recommended Posts

I've built my PSU and everything works as expected  ;D .  My only issue is as follows...

I have 2 LED panel meters that I will be using for voltage and current displays.  They are both PM129B units (http://www.circuitspecialists.com/images/PM129A&B.pdf).

I got the voltage meter to work fine, but the current meter is giving me a headache.  I am using R7 as the shunt resistor, and since I built the 5 amp version, that resistor is valued at .27 ohm.  When I connect the meter across R7, I get high reads...750-1200mV when I have a loading resistor drawing .5 amps.  The meter is set at the 200mA range.

Should I add another shunt resistor into the scheme that is better suited for this 200mA meter?  I was thinking .40 ohms.

Link to comment
Share on other sites


..... the current meter is giving me a headache.  I am using R7 as the shunt resistor, and since I built the 5 amp version, that resistor is valued at .27 ohm.  When I connect the meter across R7, I get high reads...750-1200mV when I have a loading resistor drawing .5 amps.  The meter is set at the 200mA range.

The meter is a voltmeter so it does not have mA ranges.
If it is set for the 200mV range then it will read 200mV which is too low when a current of (200mV/0.27 ohms)= 0.74A. when the current is 5A then it will try to read over-range at (5A x 0.27 ohms)= 1350mV.
If it is set to 20V range then when the current is 5A it will read (5A x 0.27 ohms)= 1.35 which is too low.

Set it to the 20V range and add a multi-turn cermet 500k calibration trimpot in series with its RA. Adjust the trimpot so that its reading is accurate.

It might need its power supply 0V connected to the power supply 0V, not the output 0V. 
Link to comment
Share on other sites


The meter is a voltmeter so it does not have mA ranges.


Yes....my mistake  :-[

Thank you



It might need its power supply 0V connected to the power supply 0V, not the output 0V. 


Could you elaborate on this please?  What is the difference between the output 0V and the PS 0V?
Link to comment
Share on other sites

Hi,
I have made two modules of picmaster's version, but I have a little issue. First of my two modules is working flawlessly regulating voltage from 0-38V and so the current limiter.
But the other visually looking the same (all parts are the same and as well interconnections) is also regulating voltage but only 0-31V and also current limiter is not working at all in one position of current setting potentiometer I have managed to get limiting diode shut (it's around 1/4 from lowest current setting) but if I move it slightly higher or lower limit indicating LED begins to shine but it is not sudden blink as in the first module, but linear, like some bulb dimmer also it doesn't matter if I move it to max current or to min current and also voltage drops only by 2-3 volts when it limits current.
Any suggestions what might be wrong here?

Link to comment
Share on other sites

Hi Josko,
Picmaster's schematic does not list its transformer voltage. It should be 28VAC or 30VAC.
The circuit should regulate the output well up to 30VDC at the output, not 38V.

Opamp U3 regulates the output current by comparing the voltage set by the current-setting pot to the voltage caused by load current in R7. When the load current is higher than the current-setting then the output voltage of U3 drops which turns on transistor Q1 on Picmaster's schematic which lights the LED. When regulating the current, the output voltage is reduced by U3 pulling down D1 on Picmaster's schematic. The output voltage of the project can be reduced to zero when the output is shorted since the output of U3 can go down as low as minus 1V. Maybe your defective circuit does not have the -1.3V supply to U3.

Link to comment
Share on other sites

Thank you for your answer,  I have 2x 29,7V AC transformer (it is 1200W this makes it 600W for one 29.7V AC on C cores so it doesn't drop under any load, actually when I shorted it once it blow up secondary (and also primary) circuit breakers instead of transformer itself :D).

Thank you for information about 30VDC I have managed to get 38VDC by adjusting RV3 (I have adjusted it to get 0 V DC when I turn voltage potentiometer to min) is it dangerous for correct operation of my circuit?

You found it! It is that -1.3V supply on defective circuit I measure something about +0.53V (I have -1.45V on correct one)  Do you have any clue what could be wrong?

Link to comment
Share on other sites


Thank you for your answer,  I have 2x 29,7V AC transformer (it is 1200W this makes it 600W for one 29.7V AC on C cores so it doesn't drop under any load .....
I have managed to get 38VDC by adjusting RV3 (I have adjusted it to get 0 V DC when I turn voltage potentiometer to min) is it dangerous for correct operation of my circuit?

29.7VAC  has a peak of 42.0V. With a full load the recifier bridge will drop 2.0V and the filter capacitor will have maybe 2V of ripple. The output opamp has a saturation loss of 1.8V, the driver transistor has a voltage loss of 1.0V, the output transistors have a voltage loss of 1.5V and the current sensing resistor has a loss of 1.35V.
The total of the losses is 9.65V. Then the max output at full load is 42V - 9.65V= 32.35VDC, not 38V.

You found it! It is that -1.3V supply on defective circuit I measure something about +0.53V (I have -1.45V on correct one)  Do you have any clue what could be wrong?

It has only a few parts. Measure them or replace them.
Link to comment
Share on other sites

I found one difference here and it's that I have -5V DC on C10 on defective circuit and -8.2 on C10 on working one.. but R8 is correct and diodes (D4, D6, D3, D5) seems to be OK too..
I'll try to replace diodes tomorrow, I'll have to go buy some new.
Zener voltage on ZD1 is the same on both circuits do I have no other suspects..
Do you know what voltage should be on C10?

And another question if I eject U3 is there any threat to turn on circuit? I want to measure voltages without U3 to check if there is no problem in it..

Link to comment
Share on other sites

Gosh I found it.. I have forgotten to solder one interconnection... stupid me.. it is when you solder at night :D
Thank you for your help.

And you are right 38 VDC was measured at no load at all I have not tested full load yet, but I have 10Ohm 100W resistor lying around so it's to to do some burn in test :)

Link to comment
Share on other sites

Where should I measure reference voltage that is used for current limiting?

And correct me if I am wrong: To get current displayed on 200mV panel meter on which circuit limits I need to just measure shunt resistor and from it's value determine voltage range for reference voltage?

Link to comment
Share on other sites


Where should I measure reference voltage that is used for current limiting?

The voltage across the current sensing resistor is compared by opamp U3 to the voltage set by the current setting pot. 

To get current displayed on 200mV panel meter on which circuit limits I need to just measure shunt resistor and from it's value determine voltage range for reference voltage?

The voltage is much higher than 200mV so a voltage divider is needed to reduce it.
When the voltage divider is calibrated then a load of 3A will read 3.0A. A load of "2A" will read "2.0A".
All digits on the meter will not be used.
Link to comment
Share on other sites

Thank you.


The voltage across the current sensing resistor is compared by opamp U3 to the voltage set by the current setting pot.

So it is voltage between 3 and GND? I understand that it compares voltage between voltage which is set from reference voltage by P1 pot and voltage on shunt resistor.


The voltage is much higher than 200mV so a voltage divider is needed to reduce it.
When the voltage divider is calibrated then a load of 3A will read 3.0A. A load of "2A" will read "2.0A".
All digits on the meter will not be used.

So I understand that it has the same voltage range on shunt resistor as across shunt resistor?

That is what I am trying to figure out: On which point I could measure voltage that is directly comparable to voltage across shunt resistor? I see that there is + and - input of opamp U3, but also there is 10k R12 and also other resistors which makes me think that there will be slightly different voltage range directly on 2 input of U3.
Link to comment
Share on other sites

If you are making the 3A power supply that uses a 0.47 ohm current sensing resistor then 1A gives a voltage across it of 0.47V and 3A gives a voltage of 1.41V.

The 200mV voltmeter you use to show current needs a voltage divider to reduce the 1.41V to 30mV. The voltmeter probably needs a power supply that is completely separate from this circuit. 

Link to comment
Share on other sites

I have probably broken circuit.. I was trying current sensor and shortened output and now it is not working at all. I mean full rectifier voltage is on output. I see no smoked parts, nothing like that. It just doesnt work.
What could possibly gone wrong? I have to note that before this experiment I changed shunt resistor from 0.5 ohm to 0.3 ohm.

It seems as if current sensing is still operating.. because if I turn down current pot low enough limiting diode lights up, but still voltage doesn't goes down.. therefore I suspect driver transistor...

//Edit:
I have figured it myself, I have blown up power transistors and driver transistors .. only one power transistor is still OK.. I have replaced all power transistors and driver transistors and it's working now :)

Now I know what I did wrong: I have replaced shunt resistor and leaved trims set up for 0.5 ohm shunt resistors (for 5 Amps) that made it something about 8 Amps for 0.3 ohm resistors on full load and of course it blew up power transistors... Now I have replaced 10 Amp fuses for lower 6.3 Amp fuses so now I can't blow it up :) Only surprising thing on it is that there was no smoke or any sign of broken transistors, I had to measure them to see that they are broken..

Link to comment
Share on other sites

I have one last question (probably). As I understand using only two TIP3055 transistors for 5A power supply is not possible, how many transistors do I need for 5A versions and then what modifications to picmasters circuit do I have to make?
I mean I know that I have to add parallel transistor or better another two, but do I have to change emitter resistors for lower value too?
And also assuming that I'll probably use 4 parallel transistors do I have to change driver transistor too?

I'm asking because shorting circuit with two transistors on 5A obviously blow up transistors (although with no sign of overheating - a have two fans inside old AT computer case which makes good airflow through heatsinks) and I want to make that power supply reliable.

Link to comment
Share on other sites


I have one last question (probably). As I understand using only two TIP3055 transistors for 5A power supply is not possible, how many transistors do I need for 5A versions and then what modifications to picmasters circuit do I have to make?
I mean I know that I have to add parallel transistor or better another two, but do I have to change emitter resistors for lower value too?
And also assuming that I'll probably use 4 parallel transistors do I have to change driver transistor too?

We already discussed a 5A power supply. Two output transistors will get too hot when the current is 5A and the output voltage is low or shorted so 3 output transistors are used, each with a 0.33 ohm emitter resistor and a very large heatsink. The single BD139 driver transistor will be fine but it needs a medium size heatsink.
The current sensing resistor is changed to 0.27 ohms at 10W.
The transformer is 28vAC or 30VAC at 212VA (7.1A).

Link to comment
Share on other sites

Is it much of a problem if I have 0.33Ohm 15W (three parallel 1Ohm 5W) shunt resistors instead of 0.27?

I think that it's ok, but I have calculated voltage divider for 0.33Ohm to my 200mV current panel meter that makes 1.65 volt show as 5Amp
which I think is OK - 5Amp through 0.33Ohm is R*I that is exactly 1.65V.
But in fact when it shows something around 3.5A on my panel I get 5Amp on my multimeter when I measure current through 4.2Ohm resistor (on my output terminals).
And what is even stranger is that on the other module with the same panel meter (exactly the same I have switch on it to choose left or right module) when I set 4Amps I get exactly 4.5 Amps.. Is there any way to correct it?

I measure reference voltage between + input of U3 and GND is it right?

Link to comment
Share on other sites


Is it much of a problem if I have 0.33Ohm 15W (three parallel 1Ohm 5W) shunt resistors instead of 0.27?

It does not matter because you adjust the calibration resistor for your meter so it reads correctly.

But in fact when it shows something around 3.5A on my panel I get 5Amp on my multimeter.

Your panel meter reads wrong because it is not calibrated or because it is powered from the same supply that it is measuring.
Your multimeter has its own shunt resistor that is in series with the measurement so its reading is actually a little lower than the actual current.

I measure reference voltage between + input of U3 and GND is it right?

Your panel meter is supposed to read the voltage across R7. Since the voltage across R7 is much higher than the 200mV maximum of the panel meter then you need a callibration voltage divider trimpot to calibrate it.
The panel meter probably needs its power supply to be completely separate from the voltage it is measuring.
Link to comment
Share on other sites

Thank you for your answer.
I'll explain you my setup:
I have separate winding on transformer for 9V supply of fans and panel meters so it is completely separate from measured voltage (voltage meter works OK).
I also have voltage divider set up to divide 1.65V to show as 5A = that is 50mV on 200mV panel with adjusted decimal point.

I think that problem is that I thought that I should measure voltage on that + input if U3.
But if I measure current on R7 (shunt resistor) I'll get current in circuit, but I would like to see current of limiter, because if I use this power supply I need to set up current limiter to some value...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
  • Create New...