Jump to content
Electronics-Lab.com Community

programming the atmega 328p microcontroller previous article on this subject


Recommended Posts

Pretty sure now of the problem I have  downloading to the atmega 328p from Jaycar with the uno bootloader. I have been using the nano board.I do have the uno board but didn't like it as you have to plug in a lot of wires to use it. I have been using the nano board for a long time now as you can plug it in directly to a solderless breadboard. Tried picking uno board in tools menu. Didn't work. It appears then that my only option may be to use the uno board as it has the uno bootloader.

Is that all I can try now? Didn't actually notice before that the Jaycar atmega 328p used a uno bootloader. Could there be an option in tools somewhere to use the uno bootloader but retain the nano board?

Link to comment
Share on other sites

It is not clear to me what you are trying to do. You say  " I have been using the nano board for a long time now ".  So you must have loaded programs into it?

The Nano uses the ATmega328 the same AVR as the Uno.

"Tried picking Uno board in tools menu".  ?   The Nano board is listed in the list of boards in the IDE is it not?



"follow the links to the page that starts with; "

Installing the AVR core

The classic Arduino boards, including the favorites UNO, Nano and Mega, requires the AVR core to be installed to compile and upload sketches to your board.

Fortunately, the classic IDE comes with the AVR core already pre-installed. This means that we only need to download and install the editor to start using our Arduino products.

Link to comment
Share on other sites

Hi Harry, You asked me what I am trying to do. I have connected everything as in the article. I am trying to program an atmega 328p which has a uno bootloader installed. This MCU is from Jaycar electronics. All the articles I can find talk about burning a bootloader. But if the bootloader is already installed you don't need to burn one.

Anyway I tried uploading the Arduino blink example as in the article. The upload never finished. I had this same problem in the past when I didn't have 'old bootloader' selected. The upload never finished. I am thinking that I may have to find uno bootloader somewhere on the arduino ide for the upload to work. Any suggestions on how I could somehow use the uno bootloader? The programs I want to upload were all worked out on a nano board. I don't know if that has anything to do with the problem. Perhaps if I had done the sketches on the uno board I wouldn't have the upload problem. 

Link to comment
Share on other sites

There are numerous videos on Youtube on uploading to the Atmega328.

This video has three ways to up load to the Atmegs328. Two methods use a UNO and one using  the FTDI. The second method using the UNO gives one insight into how the loading process works.


Also this one uses the FTDI and uploads as an UNO board (if I put the url in here even as text the stupid  video gets inserted here and I see no way to delete it).

Search on " 1-Day Project: Build Your Own Arduino UNO for $5  " on Youtube.  Some of these may give you insight to your  problem. The circuit from the article may  not be the best. Seeing what  circuits  they use maybe helpful.


I am having a $%^*& time  with this post! This my third attempt.

Link to comment
Share on other sites

Hi Harry, Did I mention that I am using a 'usb to serial/ttl adapter' connected to a duinotech atmega 328p mcu with an already installed uno bootloader. Both items purchased from Jaycar. The upload seems to go ok but never finishes. Finally I get message 'programmer not responding, not in sync'. Another message was 'can't find file referred to'. I think you are calling the adapter a FTDI. I have been trying to upload the 'blink' example as in the article. Like everybody else I like to get to the bottom of why something is not working. Not satisfying when you can't. 

Had some trouble installing the mcu on my solderless breadboard because of the large number of pins. Had to bend them in a bit. Looks like I may just have to use the uno board to program the mcu and then remove it from the board if I want to use it in a circuit. Of course an embedded mcu is the way to go but I don't have the technology to do that. 

The program on my nano board is now a mass of wires and switches and hardware. What the program does is quite marvelous but I wont go into that as I will be applying for a patent on it. A manufacturer will need a custom PCB to contain an embedded MCU as on my nano board.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...