Jump to content
Electronics-Lab.com Community

wrecked my Epson R280

Recommended Posts

---- PROLOGUE ----
so i purchased a second hand Epson R280 for direct to PCB etch resist printing. it needs no modification at all, as you can simply put the pcb on the CD printing tray. eezy peezy... well, it's color balance is always off, but other than that i have no complaints.

well, i was doing some adjustments. i had the copper clad piece taped down and the tape gets caught in the ink head and there were smudges. didn`t worry about it  since it`s happened before. so, to make sure that smudges have been cleared out, i tried printing on paper sheets. on the 3rd or so print, the paper wasn't loading properly. it was crumpling. i thought it was probably a small piece of paper or tape that got caught in the gantry or whatever. when i tried to print again, to make sure, it won't respond at all. so i did a more thorough check and saw a bottle cap in the paper loading tray.... (fcK!). with all the mess in my room, that wasn't at all that unlikely to happen.

then i inspected the loading tray more carefully and somewhat figured that for the last time it loaded a piece of paper, the bottle cap got caught on the rollers and dislodged the rollers.
---- PROLOGUE ----

now, this is the part that i shouldn`t have done... i disassembled it and figuring there wasn't going to be a problem, plugged in the power and turned it on. there slight buzz from the circuitry and then it suddenly turned off, followed by a faint smell. not a burnt smell, you know the smell when you open a new electronic gadget?? that sort. it won`t turn on again after that.

then i checked and then saw that one FFC (Flexible flat cable) were not in the socket when i turned it on. i was careless (i was worked up by the fact that i might have wrecked this one permanently). it probably got pulled out when i was disassembling it.
perhaps that fried the main board? then again, the FFC leads to the print head, so a disconnection there is unlikely to cause major damages. or would it??

maybe i probably should`ve just re-lodged the rollers using pliers, without having to open the whole thing...

what do you guys think? can this be fixed??

Share this post

Link to post
Share on other sites

Here's the service manual.  Everything can be fixed, the question is how hard is it to get the parts and is it worth it.

yeah, already have a copy of that manual before i went here. i first checked the PSU and it SEEMS like it's in good condition. when i measure the output (if you  could cross reference it with the manual, pg 124), from ground (CP52), CP51 is 42.7V and CP53 is 41.7V. i'm not completely sure if CP53 is ok, as i don't know even what's "PSC" is supposed to be. but these are the measurements. no burning components.

then i unscrewed the main board, inspected it (visually seems ok), then plugged it all back in (with the aforementioned FFC that got disconnected when i first disassembled, then connected the PSU. when i press the power button, there is very momentary LED lightup in the adjacent button used for checking ink levels, then never powers up. there's also a bit of a click in the PSU.

the mainboard  has 2 power transistors. TO3034 and TO3043. (http://obrazki.elektroda.pl/2304073300_1362587659.jpg  <-- yey, seems like i'm not the only one that had problems with this printer, it's in russian, though). of the two the TO3034 (the one with a green stripe in the pic), is that one that's overheating and apparently where the faint smell was coming from. also noted that its soldered leads seems to have remelted, as it is silvery (unlike the leads of the TO3043) and the flux remelted too.

i would be happy to hear if the problem was only with either the said 2 power transistors or the PSU. since, i think that only needs minor replacements.

in case it was the power transistors, is there a possibility the ICs in the mainboard are fried too?? please tell me that the power transistors were shielding the rest of the mainboard so it's the one taking the damage.

Share this post

Link to post
Share on other sites
Guest liquibyte

The picture is very tiny and the part numbers are impossible to find with just that info.  Can you take a higher resolution picture that shows the part numbers in question?  I have no idea what either a TO3043 or a TO3034 are as I've never seen those part numbers.  Maybe someone else here has, not sure.  I'm not getting any results with a datasheet search.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...