Jump to content
Electronics-Lab.com Community

The procedure of STM32F103VCT6 cannot be downloaded by ISP


Recommended Posts


These days I met a problem about STM32F103VCT6.

After the second edition of the STM32F103VCT6 single-chip microcomputer system I made recently, I found that I could not download by ISP, and the isps did not change the circuit line completely compared with the first version. However, it is ok to use the SW download mode, and the ISP serial port can communicate normally when the program is good. Under the ISP mode, I shook hands with serial assistants send bootloader byte 0 x7f, returned to 0 x7f and 0 x79 two bytes, while the normal board should only receive a byte 0 x79. Why is this 0 x7f, has anyone encountered the same situation, and how to solve. 

The methods I have tried:
1. Replace single chip microcomputer, max232 and peripheral capacitance, serial port signal driver IC, etc
2. The power circuit has also been changed, and the first plate of power supply has been tried.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...