Jump to content
Electronics-Lab.com Community

0-30 Vdc Stabilized Power Supply


Recommended Posts

Hi audioguru,

Well, before that, I used 4 paralleled resistors of 39Ohm/2Watt. They became glowing red after 5 seconds, and smelly, too :D
A burning 2N3055 doesn't smell that well, too, I've found out ::)
The next problem with these resistors is their temperature drift meaning the current will go down after heating a several seconds.

I don't understand that 33%? Do you mean the 20,5/23.5VAC of the original trafo? I wrote something about that in my last post...

Right now, after adding 3 more windings and the line voltage being 235VAC, the ripple is gone. If I had a higher voltage rated C1, I could go even higher with the windings, but I think I will let it be as it is now. 30V/3A is a very extreme thing and I'm quite sure I won't need it anyway.

12,000µF/63V sounds quite well, but begs the question what happened to good ol' law "1,000µF/Amp and you are fine!"
Well, you never stop learning ;)

Link to comment
Share on other sites

Ehm? Maybe there's a bit of misunderstanding...

With no load, I have 23,5V. When 5,83A are drawn, the voltage would go down to 20,5V. Never tried that, but it is printed to the trafo and sounds plausible.

I don't draw that much current, therefore the voltage won't go down that far.

Link to comment
Share on other sites

Hi Thomas,
When you use the project with both windings, the average transformer current is:
1) 30VAC X 1.414 = 42.4VDC peak.
2) With a 3ADC load, the total power used is 42.4V X 3A = 127.2W.
3) The average transformer current is 127.2W/30VAC = 4.24A, plus a little for its negative supply. ;D

Link to comment
Share on other sites

Hm... Well, I didn't measure that 3VAC drop. But 4,24A is still much smaller than the rated 5,83A.

But annother thing puzzles me: The trafo is rated for sec. 20.5V, 5,83A and 140W.
20,5V times 5,83A equals only 119,52W. Something doesn't fit there ???

23,5V times 5,83A would equal nearly 140W, but why should anyone want to know the "unloaded wattage" ??? :D

Link to comment
Share on other sites


i must say that in first tests on this supply (with orginal parts list) it worked fine...the load (24V 50W light bulb) went over 30V and 2.4A...of course it had heat problems...

then i changed the  project with updated part list because i need sure 3A with 30V output...managed to obtain OPA445 for about 10 euro a piece...put two 2N3055 in paralleland so on...at first i spotted an error since i mistaken the value of R22 and mounted an 3.9Om instead of 3.9kOm...of course i burned the Q3 and LED...changed the Q3 and R22...
i still have a problem...

suplly gives output of 0 to 34 volts without any load...thats fine...
btw. i have 150VA 32Volt secondary on my trafo...

when i put load (24V 50W light bulb) my max output goes only 21V with 1.2A through this load...
i messured 44V on C1 without load and 40V with load...

why cant i get more power with the load??? could i damaged anything else with my error on R22???

please help...anyone...

Link to comment
Share on other sites

Hi Costa,
R22 doesn't have anything to do with regulation.
When its output voltage drops under load, does the current regulating warning LED light? Does it light when you short the supply's output?

Turn the voltage and current pots to max. Measure the voltage of U2 pin 6. With a load it should increase a little. ;D

Link to comment
Share on other sites

Turn the voltage and current pots to max. Measure the voltage of U2 pin 6. With a load it should increase a little.

Hi Costa,
The current regulator doesn't work at max current setting and a shorted output.
The voltage regulator doesn't work with a load because you measured U2 pin 6's voltage dropping.

It sounds like Q2 is shorted base to emitter or its collector is disconnected or faulty. Make sure you don't have its emitter and collector pins reversed.
Make sure that R15 is 100 ohms by measuring it.

Please make more voltage measuements with the voltage and current pots to max and measure with and without a load like before:
1) Base, emitter and collector of Q2.
2) pin 3 of U2.
3) Pin 6 of U1 and U3.
4) Pin 7 of U1 and U3.

One or more of these new measurements will pinpoint the location of the problem. ;D
Link to comment
Share on other sites

tnx audioguru...
found the problem...i misconnected the pins of Q2...
now i can get full power on the output...
i messured the voltages that u asked... my load draws 1.5A on max.output voltage of 34V...current limiter lights the led when utput is shorted but it doesnt turn the output off (my a-meter shws 2 amps)...is this normal???

Q2 base , 34.6V noload , 34.5V loaded
Q2 emiter , 34.1V noload , 33.7V loaded
Q2 collector , 40.2V noload , 35.5V loaded

U2 pin6 , 34.6V noload , 34.4V loaded
U2 pin3 ,  10.8V noload , 12.0V loaded

U1 pin6 , 10.6V noload , 12.1V loaded
U1 pin7 , 40.3V noload , 35.5 V loaded

U3 pin6 , 39.3V noload , 34.7V loaded
U3 pin7 , 40.3V noload , 35.5V loaded

i guess this values are ok...your opinion???
btw. i used BD243C for Q2 and Q1

Link to comment
Share on other sites

my suplly still lacks power...
i connected two light bulbs in parallel to see if it goes to 3 amps...
it doesnt...since one draws 1.5Amps on 32V two sould draw 3 amps...
current limiter of the suplly limits this load to 2.2A on 18Volts...with both pots to max...
please help... 

Link to comment
Share on other sites

Hi Costa,
It is good that you corrected the mis-wiring of Q2. ;D
Your current regulator works, but gives only about half the current that it should. It uses R7 as a current-sensor which is in series with the load at the project's 0V output terminal, and R17 to measure its voltage drop at the negative terminal of C1.

Your voltage measurements reveal something very strange, the reference voltage for the project is the output pin 6 of U1 which should never change, but yours increases 1.5V with your load! :o
About the only way I can think of for this to happen is if the lower end of R4 is connected to the lower end of C1 by mistake, instead of to the output 0V terminal. U1 feeds the current setting pot so the max output current is increased, hey there is another problem!
Please check that the lower ends of

Link to comment
Share on other sites

Hi everyone!

I've built this power supply but it doesn't work...at output it gives 0.2V all the time! Strange thing is when I disconnect power, voltage rises to 2.9V and then lowers to 0V! And U2 is SO DAMN HOT just after few seconds after powering up!

I've been using some modified components from the list and also I modified PCB to nicely put TIP31 tranzistors; and I putted 7805 and 7905 voltage regulators to make +-5V for 7 seg LED voltmeter project also from this site...

I use 10 000uF cap, 25V 100VA trafo, 2 2N3055, and I hadn't found even opa445 or other two suggesteg OP AMPs in store so I left TL081..

Well, in theory, I think I didn't made any mistake in circuit projecting, but I get these errors:

7905 on out gives 0.7V drop, not -5
7805 works great

LED indicator is up all time, no matter how I turn pot..
Output voltage is all time 0.2V

And this are values that I measured in circuit:

PIN 6 10.3V
PIN 7 35.4V

U2 (very HOT!)
PIN 1 0
PIN 2 0.2
PIN 3 10.2
PIN 4 0
PIN 5 0
PIN 6 0
PIN 7 35.7
PIN 8 0.3

PIN 6 35
PIN 7 35.6

E 0
B 0
C 0.6

E 0.2
C 35.5
B 0

C 24.9
B 35.1
E 35.8

C 35.5
B 0.2
E 0.2

Current pot:
13 - 1.6V
6 - 1.6V
11 - 0V

Voltage pot:
5 - 10.3V
12 - 10.3V
10 - 0V

R1 35.7
R2  4.7
R7 0V (?)

D5 3.7V
D7 0V
D8 5.1V
D9 25.6V
D10 0.1V
D11 0.2V

C1 34.8V
C2 3.1V
C4 9.5V
C5 35.6V
C7 0V

Well, that's what I've measured...hope it helps because I need soon to finish this project ;D

Link to comment
Share on other sites

Hi Divljo,
Welcome to our forum. ;D
I think your U2 gets very hot and its output measures 0V because either the pcb is shorting its output to 0V, or the TL081 has failed because the total of 35.7V positive supply plus the 5.6V negative supply (when it first worked) far exceeded its absolute max total supply voltage rating of only 36V. It is probably causing the -5.6V negative supply to collapse.
It is strange that you measure 0.6V at the collector of Q1 when it is connected to the output of U2 which measures 0V.

Maybe you have Q1 installed backwards so it is shorted C to E because of it and is causing the problem with U2.

U2 is probably destroyed now and needs replacement. ;D


Link to comment
Share on other sites

Hi Divljo,

The 7805/7905 circuit seems strange to me... You know their pinout is different from each other? Pin 2 is ground with 78xx, but input with 79xx. Why are they connected with each other?
Plus, filter caps are missing near those voltage regulators. Maybe they will get unstable under load.

Link to comment
Share on other sites

Hi Thomas,
R23 and R24 are added to make what looks like a psuedo 0V for the 7805 and 7905 regulators. Then maybe the 7805 will have an input voltage within its 35V absolute max rating and the 7905 will have an input voltage higher than -7V or -8V so that it doesn't drop-out.

I think that R23 will melt due to the high positive supply current for all the LEDs in our LED display DVM project. And the 0V supply voltage for it will wander all over the place.
I thought the DVM cannot measure its own supply anyway. ???

Link to comment
Share on other sites

My mistake for Q1! It has 0.6 drop at base, not at collector!
So, U2 is dead now? I don't see any shorting and I checked it with multimeter buzzer!

Will new one TL081 work? And my R14 is 1.5K; do I need to lower to 1.2 due to my trafo is only 24V?

I've disconnected voltage regulators and R23&24 because I thought they are causing problems but everything stayed the same...and yes, that is pseudo 0V but why I get on negative side only -0.7V drop?

Thomas: Wher do you see that pin 2 is connected to the input of 79xx? pin2 of both regs are connected to gnd!

btw audioguru, are all other voltages except U2 proper?
And is there any other op amps possible to put except 445 and two others which name i don't recall now ;D ?

Link to comment
Share on other sites

Hi Divljo,
R14 is fine as 1.5k with your transformer.

Maybe the 7805 and 7905 regulators were shorting the negative supply. ???
Maybe one of the negative supply's parts failed. ???
Maybe D5, D6 or D7 is mounted backwards. ???
Without a negative supply, U2's output will go as high as it can, but Q1 would be turned-on hard without a negative supply and pull-down U2's output. Therefore all the current from U2's max output, maybe 30mA was with the 36V across it and resulting in a power dissipation of 1.1W or more. If it is soldered to the pcb instead of being in a socket, its inside temperature would be 118 degrees C which is less than its absolute max rating. It might be OK but I would replace it anyway. ???

It is best to try it again without Q1. When the project works OK you can connect Q1 later. ;)

I don't know about any other high supply voltage opamps except the three I found. Two are rated at 44V which is close with your low voltage transformer. ;D

Link to comment
Share on other sites

I disconnected Q1 and it works! With Voltage pot I can change from 32 to 2.4V but there is more turning space and when I turn, voltage rises instantly to 35V!

LED is always on, no matter where I turn Current pot

I connected 50W 5Ohm resistor and then voltage drops to 22.9V max and minimum is 2.5V, and once again, at same end of pot, voltage rises to 22.9V

Current is controlled from 4.47A at max to 0.47A. And here I get again 4.47A at same end of pot!

I just figured out that I cannot control current output! If it stands at lowest value (0.46A) Voltage pot must be also at lowest value (2.5V) When I increase voltage, current also goes up...wtf? ???

I just burned my finger on 2N3055 where I connected collector wire! Other one that is connected through heatsink is only warm! Is that normal? This is at minimal current and voltage...

Link to comment
Share on other sites

Hi Divljo,
Great! It works!
[move] ;D ;D ;D  ;D ;D ;D  ;D ;D ;D                ;D ;D ;D  ;D ;D ;D  ;D ;D ;D                ;D ;D ;D  ;D ;D ;D  ;D ;D ;D[/move]
I think the voltage adjust pot has a mechanical short inside where its slider touches one end of its track at a certain position. Also it doesn't go down to zero.

The current regulator works by adjusting the output voltage to an amount that allows the set current to flow. If you set the voltage high, set the current pot to 1A and use a 5 ohm load then it will give a 5V output with the warning LED indicating that the current regulator has reduced the output voltage.
Without a load or with the voltage set low enough or the current set high enough for a load, the warning LED should not light.

You should be able to set the current from a couple of mA to 3A.

One 2N3055 doesn't heat like the other because both need a good electrical wire connection at each collector. The heatsink conducts current poorly and the thermal grease between each transistor and the heatsink conducts current poorly too. ;D

Link to comment
Share on other sites

Well yeah, it works at last ;D

But current pot isn't doing nothing! No matter where I turn him, current stays the same! Voltage and current is cotrolled through voltage pot! And yes, they are properly connected, there is no problem with that...

And what with Q1? Why isn't circuit working with it?

And I connected VoltMeter and it showed -000 and I connected out of the power supply and from then VM shows 000 and on last segment b,c and g segments are flashing! And display is half seconds brighter and then some time is normaly lighted and again brighter and so on... I think I burned 7107 ;D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...