Jump to content
Electronics-Lab.com Community

Simulation in Linux?


Recommended Posts

Ante, free software is different form freeware see: http://www.gnu.org/philosophy/free-sw.html for a definition. When you buy a PC with Windows XP pre-installed the cost of Windows is included in the price, and you can also buy PCs with Linux pre-installed.

I personally like Linux but I have not had much luck with it as everything is designed for Windows because of Microsoft's monopoly, sucks doesn't it?

Link to comment
Share on other sites

hey Ante, have you aver try to use a pentium 3 500MHz and stend up a firewall, proxy, mail, web, dhcp, dns, ftp and other services with windows? if yes how it works? (Deadly slow) and you Alun how many hours have spent antil all this works fine?
So any software have advandage and disadvandage

Link to comment
Share on other sites

I think a 486DX-66 with a lot of RAM can serve well as a web, ftp, mail and other servers if it is using Linux. :P

Be honest, still, no Linux platform is as user-freindly as Microsoft does..... that is why I still using MS and pay some bucks to Bill Gates.

Anyway.... back to the original topics.........

Have anyone tried to use the free simulator of Linear Technology??

Link to comment
Share on other sites

I work as a systems administrator in an informatics laboratory in the University of Athens. When I talk with the other admins I always see strong opinions - some love Win, others hate it. And most of these persons are most educated and
extremely skilled in operating a variety of machines and operating systems. So it is nearly impossible to reach a justifiable conclusion in a single thread. Why has this distro war started? All I wanted to know was which is the best free soft for WinXP and which one for Linux :)

Link to comment
Share on other sites

Hmmmm....Looks like a "war" to me, but I won't get involved in it other than to say that anyone who eschews Linux simply hasn't tried it, or hasn't given it a fair hearing.
Usability objections were actually overcome a while back, so the "slice-level" generally separates die-hard m$-only gamers from the rest of us. Asi es la vida.

You can run the "old school" version of Orcad under DOS emulation in Linux. It's possible that later versions of Orcad will run under WINE, but I quit keeping up with the proggie when they went windoze-only, so I can't give a definitive "yes" or "no" to any question of "will it work?"

You could try dual-booting distros, and go with something like SimplyMEPIS-2004.06 and pick up the Debs through Kpackage or Synaptic. Might be the easiest way of doing the install, instead of compiling the sources. (gEDA actually looks like something I'll try myself.)

XCcircuit, Dia, Electric, KSimus, PCB and QCad are all possibilities for design/sim software for your stated needs; each one having its respective strengths and weaknesses, of course, so YMMV.
The above are FOSS programs and, thus, are primarily directed away from the legacy software market; although you may find that some have been back-ported to various flavors of windoze.

I can't offer anything productive to your secondary-search for zero-monetary-cost schematic design & simulatiors for xp, since I've never used m$ software in my business or for personal use.

A SourceForge search might still yield something for you in that venue though, and you might even find something that you like that is in the process of back-porting to legacy platforms (or soon will be).

Link to comment
Share on other sites

If I may ask...which distro are you running?

My question is occasioned by what sounds like problems with RPM or source dependencies in your case. They can, needless to say, be frustrating. (By the sound of the unmet dependencies you've mentioned, I'd even go so far as to hazard the guess that you're running some flavor of SuSE or Fedora Core.)

You may find that the manner of dependency resolution with a Debian-based distribution like SimplyMEPIS or Kanotix will allow you to successfully install the gEDA Deb without the kinds of problems you're presently encountering.

Uninstall is generally a matter of deleting the applicable directory in /usr/lib/, or /usr/share/ or /opt/; the associated binary in /usr/bin/ and the respective links to the application. Once you've done it a few times, you develop a feel of where to look, getting it right the first time.
In the end analysis, this is much quicker and easier than dealing with a flakey "unwise.exe", the inevitable registry dross and a "strange acting" OS platform in the wake of the application removal.

If you type "make clean" in the directory you're working with source code in, the object files and other temporary files are deleted, and you can start a compilation run again. (For future reference.)

::: a bit of time passes :::

I have to laugh at myself a bit here, because it looks like I've been too busy lately.
I was considering installing gEDA, because it looks like something I could get a kick out of using but, as it so happens, I already have it installed and I simply wasn't aware of it. From what I can tell, it was amongst a block of around 400 programs I installed a few weeks back. I guess I'll have to give it a whirl one of these days.

How about a suggestion? :D
Since you've already re-installed your distro once, you really don't lose anything by trying the following...

Open up a console session* and:

[email protected][example.user]$ su
[email protected][root]# mkdir /distros
[email protected][root]# cd /distros
[email protected][distros]# kwrite ./getsm2004.06.sh

enter the following lines:

wget -c ftp://ftp.ibiblio.org/pub/linux/distributions/mepis/released/SimplyMEPIS-2004.06.iso.md5sum
wget -c ftp://ftp.ibiblio.org/pub/linux/distributions/mepis/released/SimplyMEPIS-2004.06.iso

and close the file, then:

[email protected][distros]# chmod 755 getsm2004.06.sh
[email protected][distros]# nohup ./getsm2004.06.sh

You'll get "Appending output to nohup.out" as your response. You can close the console session and surf, do your work, listen to CDs and OGGs, do whatever you want, letting the download continue until it's finished...even logout if you desire...just leave the machine up and running. As popular as this release currently is, the download will stall and lose the connection to the server. Not to worry, since wget will pick back up where it left off when the connection is re-established. When that's done, you can check the md5 against the .iso and make sure you have an uncorrupted file; then burn it to a blank CD-R; the easiest way of doing that being at the command line:

[email protected][example.user]$ su
[email protected][root]# cd /distros
[email protected][distros]# /usr/bin/cdrecord --scanbus
Cdrecord-Clone 2.01a34 (i686-pc-linux-gnu) Copyright © 1995-2004 Jörg Schilling

Linux sg driver version: 3.5.31
Using libscg version 'schily-0.8'.
        X,Y,Z     ?) Something that indicates that it's your CD-Burner

write down whatever "X,Y,Z" happens to be and use it in the next command (replacing "speed=16" with the burning speed appropriate to your drive):

[email protected][root]# /usr/bin/cdrecord dev="X,Y,Z" fs=8192k driveropts=burnfree -v -useinfo speed=16 -dao -eject -pad -overburn -data "/distros/SimplyMEPIS-2004.06.iso"

Watching this screen is boring, so watch Rin & Stimpy, or some old Hawaii-50 reruns. When the CD's out of the oven, boot with it and login as root. (You get 3 guesses what the root password is for the Live-CD portion, and it's not "password".) You should have an "Mepis Installation Center" icon on the root desktop. livecddesktop.png Click on it and go through about a 10 minute installation process which will be done on the first and only re-boot. Login as a normal user (if you created one, and you should have). Run another console session. su again.

[email protected][root]# apt-get update; apt-get upgrade; apt-get install synaptic

You'll get scrolling text and maybe a couple of questions (go with the defaults) and you'll be done. Suffice it to say that you've:
1.) updated your local repository listings,
2.) upgraded your OS and applications and
3.) installed the Synaptic package manager, if you prefer to use that instead of Kpackage;
in a single shot.
Close the session because for the next one we'll use the GUI to do the quick install.

Run: K -> System -> Kpackage
Settings -> Configure Kpackage... -> Types -> APT: Debian
Enable and click "Location of Packages" -> A1
Make sure the package locations and enablement agrees with those shown in the attached screen shot.
Close that up and...

Click on the blue, "Reload" button on the left.
Browse the repository tree to:
DEBAPT -> electronics (10th sub-directory) -> geda (13th package in the directory)
[ Or just do a "Find File" on the text: geda ]
Mark geda, and the 7 packages below it, for installation (see the attached screen shot).
Wander around and see if there are any other programs you'd like to install as well.
Click "Install Marked" and sit back while everything happens.
At most you'll be told that one or two additional packages are going to be installed to satisfy dependencies for geda or a geda component.

When that's done:
K -> System -> Settings -> MenuEditor
Create a new menu item (I put mine under Applications -> Browse All -> Apps -> Technical) with a command invocation of: /usr/bin/geda
Choose an icon for it, and save the configuration.
Run gEDA in the usual GUI manner.

Remember that there is some poor sap out there who is on his 3 or 4th reboot, on a legacy OS install that he started before you started installing Mepis. He still has yet to run windoze update and install apps; while you have a fully-usable, updated and secure installation right now.

Anyway, if you don't want to bail-out on the distro you have now, I still think you'll find something to your liking in what is already out there; and the above can be relegated to the realm of the academic, or simply ascribed to my propensity for writing really long posts :o .

*For all those GNU/Linux detractors out there, I'm giving autir command line instructions that will work on any distribution or release of GNU/Linux. I don't have to know anything about his system, distribution, GUI or installed programs for this to work correctly.


Link to comment
Share on other sites

Thanks for the feed EnigmaOne. But I am a minimalist... using Slackware and fluxbox WM. No Gnome, KDE, apt-* utils. And I will not change my distro ;)

Far be it for me to suggest such a change! ;)
In the past, I changed distros almost as often as I changed my socks--finally settled on LFS and Mepis as my favorites--so I instinctively go for distro changing/dual-booting to get over a temporary obstacle.

You did push me into playing with gEDA for the past few days, and I think I've found a new favorite editor. I can finally dump my Orcad/DOS emulator combo, import all my custom symbol files and go strictly with gEDA on current/future projects.

It certainly is worth the hassle of getting the dependencies lined-up and compiled; although, I never would have believed anyone if--before seeing gEDA--they had said the same thing to me.

Maybe a dual-boot (Slack/Debian) set-up is in your future? ;)

Anyways, thanks for mentioning the proggie. I now have a symlink to it on my DT.
Link to comment
Share on other sites

  • 4 months later...


I don't want to discuss about windows versus linux. I use the both in my job and linux at home.

For electronic design under Linux I use a capture, PCB software call Kicad (also works under windows)

Designed and written by Jean-Pierre Charras, a researcher at LIS (Laboratoire des Images et des Signaux) and a teacher in  IUT  de Saint Martin d'Hères.(France), in the field of electrical engineering and image processing.

Kicad is a set of four softwares and a project manager:

    * Eeschema: Schematic entry.
    * Pcbnew: Board editor.
    * Gerbview: GERBER viewer (photoplotter documents).
    * Cvpcb: footprint selector for components used in the circuit design.
    * Kicad: project manager.


For the simulation Kicad can generate a netlist for spice softwares. I use gspiceui with ngspice an gnucap.

Best regards,

Link to comment
Share on other sites

Guest Alun

Sounds interesting, I also like Linux but I mostly use Windows as Linux lacks electronics software and Wine can't reliably run the simulation software I use.

How does all of this work?

Do you draw the schematic in one program and then simulate in anouther?

Or is it like Electronics work bench where you draw the schematic and then watch the simulation on the screen?

Link to comment
Share on other sites

Hi Alun,

I use Kicad for the schematic and for the PCB.

I use gspiceui for the simulation and viewing the simulation.

You can test Kicad under linux or windows. Under windows I think you can use pspsice for the simulation as Kicad can generate a spice file.

Best regards,

Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...

For Schematics and simulations, give a try to LTSpice. It is a very good full and free Spice simulator.  For download:


If you also want PCB prototyping, give a try to WinQCad. For download a demo version:


Both programs run on Linux under Wine.

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...